Bug #1046

Settings file issue

Added by Rob Baer over 2 years ago. Updated almost 2 years ago.

Status:NewStart date:08/16/2016
Priority:LowDue date:
Assignee:-% Done:

0%

Category:-
Target version:MakeHuman 1.1.2

Description

r2067 Hg default on Windows 10

It seems we need adapt the settings files to handle version change to 1.2.x:

Incompatible MakeHuman settings (version 1.1.0) detected (expected 1.2.0). Loading default settings.

History

#1 Updated by Jonas Hauquier over 2 years ago

Not necessarily. I made it so that good defaults would be assumed when upgrading from 1.0 to 1.1
There's other applications that do a similar thing.
But the test is probably made generic and the same will happen when going from 1.1 to 1.2, and perhaps indeed we want to handle this case more gracefully, given the small differences.

#2 Updated by Rob Baer over 2 years ago

  • Priority changed from Normal to Low

Well, yes. It is just a warning, and the program behaves well. If the settings DON'T change this is not much of a problem.

I document it because it has the potential to need "plan" for "graceful handling" as you say, as versions changes. We haven't yet stepped too far into 1.2.x yet, but 1.1.x assets don't yet open in default because the "comparability layer" for the version change is not yet implemented. This seems like a lesser but similar kind of grunt work that goes with some version change handling.

Anyway,thought this should be on our list, minor as it is. I'll set the priority to low.

#3 Updated by Aranuvir # almost 2 years ago

  • Target version set to MakeHuman 1.1.2

Is this currently a problem? Moving it to 1.1.2

Also available in: Atom